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Note:  Our intent is that you try this problem on your own first.  After you have solved it on your
own, you can step through our solution if desired.  If you have problems trying to create the
model, then follow the steps in our solution.

Building Description
The building is a four-story concrete shear wall building with concrete flat slabs
supported by concrete columns.  There is a 30 foot high steel flagpole on the
roof at one corner of the building.  A 250 pound man sits on top of the flagpole.

Steel
E =29000 ksi
Poissons Ratio = 0.3  
Flagpole is 3"  ∅ standard pipe

Concrete
E =3600 ksi
Poissons Ratio = 0.2  
Walls are 12" thick
Columns & beams are 20" x 20" 
Floors & roof are 10" thick flat slab

Response Spectrum Loading
X-Dir (U1):  1994 UBC S2
Y-Dir (U2):  30% of 1994 UBC S2
  
Assumptions
• Diaphragms are rigid in plane.
• Columns are fixed base.
• Consider the mass of the

250 pound man which is
0.00065 kip-sec2/in. 

  
To Do
Determine maximum X-direction
(U1) displacement at top and 
bottom of the flagpole for the
specified response spectrum
loading.

Problem Z
Response Spectrum Analysis 
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Problem Z Solution

1. Click the drop down box in the status bar to change the units to kip-ft.

2. From the File menu select New Model From Template…. This displays the Model
Templates dialog box.

3. In this dialog box click on the Space Frame template button                      to display the
Space Frame dialog box.

4. In this dialog box:

• Type 4 in the Number of Stories edit box.

• Type 4 in the Number of Bays Along X edit box.

• Type 4 in the Number of Bays Along Y edit box.

• Accept the default Story Height, 12.

• Type 30 in the Bay Width Along X edit box.

• Type 30 in the Bay Width Along Y edit box.

• Verify that the Restraints and Gridlines check boxes are checked.

• Click the OK  button.

5. From the Draw menu select Edit Grid...  to display the Modify Grid Lines dialog box.

6. In this dialog box:

• Check the Glue Joints To Grid Lines check box.

• Verify that the X option is selected in the Direction area.

• Click on the -30 grid line in the X Location list box to highlight it.  The -30 value
appears in the X Location edit box.

• Type -35 in the X Location edit box and click the Move Grid Line  button.

• Click on the 30 grid line in the X Location list box to highlight it.  The 30 value appears
in the X Location edit box.

• Type 40 in the X Location edit box and click the Move Grid Line  button.
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• Select the Y option in the Direction area.

• Click on the -30 grid line in the Y Location list box to highlight it.  The -30 value
appears in the Y Location edit box.

• Type -40 in the Y Location edit box and click the Move Grid Line button.

• Click the OK button.

7. Verify that the 3-D View window is active.  The window is active when its title is
highlighted.

8. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

9. In this dialog box:

• Check the Fill Elements check box.

• Click the OK  button.

10. From the View menu select Refresh View to update the 3-D view.

11. Click in the window labeled X-Y Plane @ Z=48 to activate it.

12. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

13. In this dialog box:

• Check the Fill Elements check box.

• Click the OK  button.

14. Click the xz 2D View button       on the main toolbar.  The view switches to the X-Z plane
@ Z=60 and appears as shown in Figure Z-1.

15. Click the Quick Draw Rectangular Shell Element button        on the side toolbar.

16. Click once in each of the area labeled “A”, “B”, “C” and “D” in Figure Z-1 to enter four
shell elements.

17. From the View menu select Set 2D View... to display the Set 2D View dialog box.

18. In this dialog box:

• Verify that the X-Z Plane option is selected.

• Type -60 in the Y= edit box.
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Figure Z-1:  Screen After Step 14

• Click the OK button.  The screen appears similar to that shown in Figure Z-1 (except
that the location is now at Y=-60).

19. Click once in each of the area labeled “E”, “F”, “G” and “H” in Figure Z-1 to enter four
shell elements.

20. From the View menu select Set 2D View... to display the Set 2D View dialog box.

21. In this dialog box:

• Select the Y-Z Plane option.

• Verify that 60 is entered in the X= edit box.

• Click the OK button.  The screen appears as shown in Figure Z-2.

22. Click once in each of the area labeled “A”, “B”, “C” and “D” in Figure Z-2 to enter four
shell elements.

23. From the View menu select Set 2D View... to display the Set 2D View dialog box.
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Figure Z-2:  Screen After Step 21

24. In this dialog box:

• Verify that the Y-Z Plane option is selected.

• Type -60 in the X= edit box.

• Click the OK button.  The screen appears similar to that shown in Figure Z-2 (except
that the location is now at X=-60).

25. Click once in each of the area labeled “E”, “F”, “G” and “H” in Figure Z-2 to enter four
shell elements.  This completes the drawing of the shear walls.

26. Click the Pointer button       to exit draw mode and enter select mode.

27. From the Define menu select Materials... to display the Define Materials dialog box.

28. In this dialog box:

• Highlight the CONC material and click the Modify/Show Material button to display
the Material Property Data dialog box.
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• In this dialog box:

À Verify that the Mass per Unit Volume is 4.658E-03.

À Verify that the Weight per Unit Volume is 0.15.

À Click the OK button to return to the Define Materials dialog box.

• Highlight the STEEL material and click the Modify/Show Material button to display
the Material Property Data dialog box.

• In this dialog box:

À Verify that the Mass per Unit Volume is 0.0152.

À Verify that the Weight per Unit Volume is 0.489.

À Click the OK button twice to exit all dialog boxes.

29. Click the drop down box in the status bar to change the units to kip-in.

30. From the Define menu select Materials... to display the Define Materials dialog box.

31. In this dialog box:

• Highlight the CONC material and click the Modify/Show Material button to display
the Material Property Data dialog box.

• In this dialog box:

À Verify that the Modulus of Elasticity is 3600.

À Verify that Poisson’s ratio is 0.2.

À Click the OK button to return to the Define Materials dialog box.

• Highlight the STEEL material and click the Modify/Show Material button to display
the Material Property Data dialog box.

• In this dialog box:

À Verify that the Modulus of Elasticity is 29000.

À Verify that Poisson’s ratio is 0.3.

À Click the OK button twice to exit all dialog boxes.

32. From the Define menu select Frame Sections... to display the Define Frame Sections
dialog box.
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33. In this dialog box:

• In the Click To area, click the drop-down box that says Import I/Wide Flange and then
click on the Import Pipe item.

• If the Section Property File dialog box appears then locate the Sections.pro file which
should be located in the same directory as the SAP2000 program files.

• A dialog box appears with a list of all pipe sections in the database.  In this dialog box:

À Scroll down and click on the P3 (3" diameter standard pipe section) item.

À Click the OK button twice to return to the Define Frame Sections dialog box.

• In the Click To area, click the drop-down box that says Add I/Wide Flange and then
click on the Add Rectangular item.  The Rectangular Section dialog box is displayed.

• In this dialog box:

À Type BMCOL in the Section Name edit box.

À Select CONC from the Material drop-down box.

À Type 20 in the Depth (t3) edit box.

À Type 20 in the Width (t2) edit box.

À Click the OK button twice to exit all dialog boxes.

34. From the Define menu select Shell Sections... to display the Define Shell Sections dialog
box.

35. In this dialog box:

• Click the Modify/Show Section button to display the Shell Sections dialog box.

• In this dialog box:

À Type WALL in the Section Name edit box.

À Accept the default CONC material

À In the Thickness area verify that both the Membrane and the Bending thicknesses
are 12.

À In the Type area verify that the Shell option is selected.

À Click the OK button to return to the Define Shell Sections dialog box.
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• Click the Add New Section button to display the Shell Sections dialog box.

• In this dialog box:

À Type FLOOR in the Section Name edit box.

À Accept the default CONC material.

À Type 10 in the Membrane edit box.

À Type 10 in the Bending edit box.

À In the Type area verify that the Shell option is selected.

À Click the OK button twice to exit all dialog boxes.

36. Click the drop down box in the status bar to change the units to kip-ft.

37. Click in the window labeled Y-Z Plane @ X=-60 to verify it is active.

38. From the View menu select Set 2D View... to display the Set 2D View dialog box.

39. In this dialog box:

• Select the X-Y Plane option.

• Verify that 48 is entered in the Z= edit box.

• Click the OK button.

40. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

41. In this dialog box:

• Check the Labels box in the Joints area.

• Click the OK  button.

42. Click the Draw Rectangular Shell Element button       on the side toolbar or select Draw
Rectangular Shell Element from the Draw menu.

43. Click on joint 25 and then joint 105 to enter a single shell element for the entire floor.

44. Click the Pointer button       to exit draw mode and enter select mode.

45. Select all elements in the X-Y Plane @ Z=48 by “windowing”.

46. From the Edit menu select Mesh Shells... to display the Mesh Selected Shells dialog box.
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47. In this dialog box:

• Select the mesh Using Selected Joints on Edges option.

Note:  The Mesh At Intersections With Grids option would work equally well.

• Click the OK button.

48. Select all elements in the X-Y Plane @ Z=48 by “windowing”.

49. From the Assign menu select Shell and then Sections... from the submenu to display the
Define Shell Sections dialog box.

50. In this dialog box:

• Highlight the FLOOR section by clicking on it.

• Click the OK button.

51. Click the Show Undeformed Shape button        to remove the displayed shell section
assignments.

52. Click the Restore Previous Selection button        on the side toolbar (or select Get
Previous Selection from the Select menu).

53. From the Edit menu select Replicate... to display the Replicate dialog box.

54. In this dialog box:

• Verify the Linear Tab is selected.

• In the Distance area type -12 in the Z edit box.

• Verify that 0 is entered in the X and Y edit boxes.

• Type 3 in the Number edit box.

• Click the OK button to proceed with the replication and create the other floor
diaphragms.

55. Click the Restore Previous Selection button        on the side toolbar (or select Get
Previous Selection from the Select menu).

56. From the Assign menu select Joint and then Constraints... from the submenu to display
the Constraints dialog box.

57. In this dialog box:
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• In the Click To area click the drop-down box and select Add Diaphragm to display the
Diaphragm Constraint dialog box.

• In this dialog box:

À Type ROOFDIA in the Constraint Name edit box.

À Select the Z Axis option in the Constraint Axis area.

À Click the OK button twice to exit all dialog boxes.

58. Click the Down One Gridline button        to move the plan display down to the X-Y Plane
@ Z=36.  You can confirm the elevation by looking on the right-hand side of the staus bar
at the bottom of the SAP2000 window.

59. Select all elements at this level by “windowing”.

60. From the Assign menu select Joint and then Constraints... from the submenu to display
the Constraints dialog box.

61. In this dialog box:

• In the Click To area click the drop-down box and select Add Diaphragm to display the
Diaphragm Constraint dialog box.

• In this dialog box:

À Type 4THDIA in the Constraint Name edit box.

À Select the Z Axis option in the Constraint Axis area.

À Click the OK button twice to exit all dialog boxes.

62. Click the Down One Gridline button        to move the plan display down to the X-Y Plane
@ Z=24.

63. Select all elements at this level by “windowing”.

64. From the Assign menu select Joint and then Constraints... from the submenu to display
the Constraints dialog box.

65. In this dialog box:

• In the Click To area click the drop-down box and select Add Diaphragm to display the
Diaphragm Constraint dialog box.

• In this dialog box:

À Type 3RDDIA in the Constraint Name edit box.
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À Select the Z Axis option in the Constraint Axis area.

À Click the OK button twice to exit all dialog boxes.

66. Click the Down One Gridline button        to move the plan display down to the X-Y Plane
@ Z=12.

67. Select all elements at this level by “windowing”.

68. From the Assign menu select Joint and then Constraints... from the submenu to display
the Constraints dialog box.

69. In this dialog box:

• In the Click To area click the drop-down box and select Add Diaphragm to display the
Diaphragm Constraint dialog box.

• In this dialog box:

À Type 2NDDIA in the Constraint Name edit box.

À Select the Z Axis option in the Constraint Axis area.

À Click the OK button twice to exit all dialog boxes.

70. Click the Down One Gridline button        to move the plan display down to the X-Y Plane
@ Z=0.

71. Select all elements at this level by “windowing”.

72. From the Assign menu select Joint and then Restraints... from the submenu to display the
Joint Restraints dialog box.

73. In this dialog box:

• Click the Fixed Support button        in the Fast Restraints area.

• Click the OK button.

74. Click the Select All button       on the side toolbar to select all elements.

75. From the Assign menu select Frame and then Sections... from the submenu to display the
Define Frame Sections dialog box.

76. In this dialog box:

• Click on BMCOL in the Frame Sections area to highlight it.

• Click the OK button.
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77. Click the Show Undeformed Shape button        to remove the displayed frame section
assignments.

78. From the View menu select Set 2D View... to display the Set 2D View dialog box.

79. In this dialog box:

• Select the X-Z Plane option.

• Verify -60 is entered in the Y= edit box.

• Click the OK button.

80. From the Draw menu select Edit Grid... to display the Modify Grid Lines dialog box.

81. In this dialog box:

• Select the Z option in the Direction area.

• Type 78 in the Z Location edit box and click the Add Grid Line button.

• Click the OK button.  The screen appears as shown in Figure Z-3.

82. Click the Quick Draw Frame Element button        on the side toolbar or select Quick
Draw Frame Element from the Draw menu.

83. Click on the grid line at the point labeled “A” in Figure Z-3 to enter the flagpole frame
element.

84. Click the Pointer button       to exit draw mode and enter select mode.

85. Click on the frame element to select it.

86. From the Assign menu select Frame and then Sections... from the submenu to display the
Define Frame Sections dialog box.

87. In this dialog box:

• Click on P3 in the Frame Sections area to highlight it.

• Click the OK button.

88. Click the Show Undeformed Shape button        to remove the displayed frame section
assignments.

89. Click the drop down box in the status bar to change the units to kip-in.

90. Click on the joint at the top of the flagpole to select it.
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Figure Z-3:  Screen After Step 81

91. From the Assign menu select Joint and then Masses... from the submenu to display the
Joint Masses dialog box.

92. In this dialog box:

• Type .00065 in the Direction 1, Direction 2 and Direction 3 edit boxes.

• Click the OK button.

93. Click the Show Undeformed Shape button        to remove the displayed joint mass
assignments.

94. Click the drop down box in the status bar to change the units to kip-ft.

95. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

96. In this dialog box:

• Uncheck the Labels box in the Joints area.

A
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• Click the OK button.

97. From the Define menu select Response Spectrum Cases… to display the Define Response
Spectra dialog box.

98. In this dialog box:

• Click the Add New Spectra button to display the Response Spectrum Case Data dialog
box.

• In this dialog box:

À Accept the default Spectrum case name, SPEC1.

À Accept the default Excitation Angle, 0.

À Accept the default Modal Combination option, CQC.

À Type .05 in the Damping edit box.

À Accept the default Directional Combination option, SRSS.

À In the Input Response Spectra area select UBC94S2 from the U1 Function drop-
down box.

À In the Input Response Spectra area type 32.2 in the U1 Scale factor edit box.

À In the Input Response Spectra area select UBC94S2 from the U2 Function drop-
down box.

À In the Input Response Spectra area type 9.66 (0.3 * 32.2 = 9.66) in the U2 Scale
factor edit box.

À Click the OK  button twice to exit all dialog boxes.

99. From the Analyze menu select Set Options... to display the Analysis Options dialog box.

• Verify the the Dynamic Analysis check box is checked.

• Click the Set Dynamic Parameters button to display the Dynamic Analysis
Parameters dialog box.

• In this dialog box:

À Type 20 in the Number of Modes edit box.

À In the Type of Analysis area select Ritz Vectors.

À Click on ACCEL Z in the Ritz Load Vectors list box to highlight it.
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À Click the Remove button to remove ACCEL Z from the Ritz Load Vectors list box.
ACCEL X and ACCEL Y should remain in the Ritz Load Vectors list box.

À Click the OK button twice to exit all dialog boxes.

100. Click the Run Analysis button       to run the analysis.

101. When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors).  Click the OK button to close the Analysis window.

102. Click in the window labeled X-Z Plane @ Y=-60 to make sure it is active.

103. Click the Display Static Deformed Shape button        (or select Show Deformed Shape…
from the Display menu).  The Deformed Shape dialog box appears.

104. In this dialog box:

• Select SPEC1 Spectra from the Load drop-down box.

• Click the OK  button.

105. Right click the joints at the top and bottom of the flagpole to see their displacements.

Note:  If the top of the flagpole goes off of the screen when the deformed shape is
displayed, then click the Zoom Out One Step button       on the main toolbar as many
times as required to bring the joint back on to the screen.


