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Note:  Our intent is that you try this problem on your own first.  After you have solved it on your
own, you can step through our solution if desired.  If you have problems trying to create the
model, then follow the steps in our solution.

Problem Q
Three Frames

Concrete
E =5000 ksi, Poissons Ratio = 0.2
Beams:  24" wide by 36"  deep
Columns:  24" by 24"  

Damper Properties
Linear Properties Nonlinear Properties

Effective stiffness = 0 k/in Stiffness = 1000 k/in
Effective damping = 0 k-sec/in Damping = 30 k-sec/in

Damping exponent = 0.5

Isolator Properties (Isolator1)
Vertical (axial) stiffness = 10,000 k/in (linear)
Initial shear stiffness = 100 k/in
Shear yield force = 40 kips
Ratio of post yield shear stiffness to initial shear stiffness = 0.1

Time History
Apply the ELCENTRO record.  Three time and acceleration values are given 
on each line of this file.   The acceleration value is in units of g.   The length
of the record is 12.1 seconds.

To Do
Create three frames, one bare, one with dampers, and one with isolators.
Create a video (*.avi file) of the nonlinear time history run.  Review the mode 
shapes.  
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Problem Q Solution

1. Click the drop down box in the status bar to change the units to kip-ft.

2. From the File menu select New Model From Template…. This displays the Model
Templates dialog box.

3. In this dialog box click on the Portal Frame template                     button to display the
Portal Frame dialog box.

4. In this dialog box

• Type 3 in the Number of Stories edit box.

• Type 5 in the Number of Bays edit box.

• Uncheck the Restraints check box.

• Click the OK  button.

5. Click the “X” in the top right-hand corner of the 3-D View window to close it.

6. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

7. In this dialog box:

• Check the Labels box in the Joints area.

• Check the Labels box in the Frames area.

• Click the OK  button.

8. Select beam elements 22, 23, 24, 28, 29 and 30.  Press the delete key on the keyboard to
delete these elements.

Note:  You could select the elements by clicking on each one individually, by using the
Intersecting Line Select Mode, or by using the Select By Labels option (Select menu >
Select > Labels).

9. Click the Refresh Window button         to refresh the drawing.

10. From the Draw menu select QuickDraw Frame Element.

11. Click on the grid line between joints 17 and 21 to enter a beam at the base of the isolated
frame.
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12. Click the Pointer button       on the side tool bar to exit draw mode and enter select mode.

13. Select joints 1, 5, 9 and 13.

14. From the Assign menu, choose Joint, and then Restraints… from the submenu.  This will
display the Joint Restraints dialog box.

15. In this dialog box:

• Click the Fixed Base Fast Restraint button        to set all degrees of freedom (U1, U2,
U3, R1, R2 and R3) as restrained.

• Click the OK  button.

16. Click the drop down box in the status bar to change the units to kip-in.

17. From the Define menu select Materials... to display the Define Materials dialog box.

18. Click on CONC in the Materials area to highlight (select) it, and then click the
Modify/Show Material  button.  The Material Property Data dialog box is displayed.

19. In this dialog box:

• Type 0 in the Mass per Unit Volume edit box.

• Accept the default Weight per Unit Volume.

• Type 5000 in the Modulus of Elasticity edit box.

• Type .2 in the Poisson’s Ratio edit box, if it is not already entered.

• Click the OK button twice to exit all dialog boxes.

20. From the Define menu select Frame Sections... to display the Define Frame Sections
dialog box.

21. In the Click To area, click the drop-down box that says Add I/Wide Flange and then click
on the Add Rectangular item to display the Rectangular Section dialog box.

22. In this dialog box:

• Type BEAM in the Section Name edit box.

• Select CONC in the Material drop-down box.

• Type 36 in the Depth (t3) edit box.

• Type 24 in the Width (t2) edit box.
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• Click the OK button to return to the Define Frame Sections dialog box.

23. In the Click To area, click the drop-down box that says Add Rectangular and then click on
the Add Rectangular item to display the Rectangular Section dialog box.

24. In this dialog box:

• Type COL in the Section Name edit box.

• Select CONC in the Material drop-down box.

• Type 24 in the Depth (t3) edit box.

• Type 24 in the Width (t2) edit box.

• Click the OK button twice to exit all dialog boxes.

25. Select all beam elements (10 total).

26. From the Assign menu select Frame and then Sections... from the submenu to display the
Define Frame Sections dialog box.

27. In this dialog box:

• Click on BEAM in the Frame Sections area to highlight it.

• Click the OK button.

28. Select all column sections by “windowing “ on each column line separately (18 total).

29. From the Assign menu select Frame and then Sections... from the submenu to display the
Define Frame Sections dialog box.

30. In this dialog box:

• Click on COL in the Frame Sections area to highlight it.

• Click the OK button.

31. Click the Show Undeformed Shape button        to remove the displayed frame section
assignments so that you can see the frame element labels again.

32. From the Define menu select NLLink Properties... to display the Define NLLink
Properties dialog box.

33. In this dialog box:

• Click the Add New Property button to display the NLLink Property Data dialog box.
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• In this dialog box:

À Type ISO in the Property Name edit box.

À Select Isolator1 from the Type drop-down box.

À Type .001 in the Mass edit box.

À Check the U1 Direction check box.

À Click the Modify/Show For U1 button to display the NLLink Directional
Properties dialog box.

À In this dialog box:

ä Type 10000 in the Effective Stiffness edit box.

ä Click the OK button to return to the NLLink Property Data dialog box.

À Check the U2 Direction check box.

À Check the U2 Nonlinear check box.

À Click the Modify/Show For U2 button to display the NLLink Directional
Properties dialog box.

À In this dialog box:

ä In the Linear Properties area type 10 in the Effective Stiffness edit box.

ä In the Nonlinear Properties area type 100 in the Stiffness edit box.

ä Type 40 in the Yield Strength edit box.

ä Type .1 in the Post Yield Stiffness Ratio edit box.

ä Accept the rest of the default values.

ä Click the OK button to return to the NLLink Property Data dialog box.

À Click the OK button to return to the Define NLLink Properties dialog box.

• Click the Add New Property button to display the NLLink Property Data dialog box.

• In this dialog box:

À Type DAMP in the Property Name edit box.

À Select Damper from the Type drop-down box.
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À Type .001 in the Mass edit box.

À Check the U1 Direction check box.

À Check the U1 Nonlinear check box.

À Click the Modify/Show For U1 button to display the NLLink Directional
Properties dialog box.

À In this dialog box:

ä In the Nonlinear Properties area type 1000 in the Stiffness edit box.

ä Type 30 in the Damping edit box.

ä Type .5 in the Damping Exponent edit box.

ä Click the OK button three times to exit all dialog boxes.

34. From the Draw menu select Draw NLLink Element.

35. Double click on joints 17 and 21 to draw two NLLink elements.

36. Click on joint 9 and then joint 14 to draw an NLLink element.

37. Click on joint 10 and then joint 15 to draw an NLLink element.

38. Click on joint 11 and then joint 16 to draw an NLLink element.

39. Click the Pointer button       on the side tool bar to exit draw mode and enter select mode.

40. Click on the three NLLink element in the center frame to select them.

41. From the Assign menu select NLLink and then Properties... from the submenu to display
the Define NLLink Properties dialog box.

42. In this dialog box:

• Click on DAMP in the NLLink Props area to highlight it.

• Click the OK button.

43. Click the Show Undeformed Shape button        to remove the displayed NLLink property
assignments so that you can see the joint labels again.

44. Hold down the Ctrl key on the keyboard and left click joint 17 to display the Selection List
dialog box.
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45. In the dialog box click on the NLLink 1 element.  The Selection List dialog box closes and
the NLLink element is selected.

46. Hold down the Ctrl key on the keyboard and left click joint 21 to display the Selection List
dialog box.

47. In the dialog box click on the NLLink 2 element.  The Selection List dialog box closes and
the NLLink element is selected.

48. From the Assign menu select NLLink and then Properties... from the submenu to display
the Define NLLink Properties dialog box.

49. In this dialog box:

• Click on ISO in the NLLink Props area to highlight it.

• Click the OK button.

50. Click the Show Undeformed Shape button        to remove the displayed NLLink property
assignments.

51. Select all joints at the 2nd, 3rd and Roof levels by “windowing”.

52. From the Assign menu select Joint Static Loads... and then Forces... from the submenu to
display the Joint Forces dialog box.

53. In this dialog box:

• Type -50 in the Force Global Z edit box.

• Click the OK button.

54. Select all joints at the 2nd, 3rd and Roof levels by “windowing”.

55. From the Assign menu select Joint and then Masses... from the submenu to display the
Joint Masses dialog box.

56. In this dialog box:

• Type .25 in the Direction 1 edit box.

• Type .25 in the Direction 3 edit box.

• Click the OK button.

57. Click the drop down box in the status bar to change the units to kip-ft.

58. Click the Show Undeformed Shape button        to remove the displayed joint mass
assignments.
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59. Click the Set Elements button        on the main toolbar (or select Set Elements… from the
View menu) to display the Set Elements Dialog box.

60. In this dialog box:

• Uncheck the Labels box in the Joints area.

• Uncheck the Labels box in the Frames area.

• Click the OK  button.

Note:  Prior to defining time history functions, you should locate the time history file
named Elcentro that is in the subdirectory named Examples beneath the directory
where you installed SAP2000.  Copy this file into the same directory as your SAP2000
input file.

If the Examples subdirectory does not exist you may need to reinstall SAP2000, and
select to install the examples.

61. From the Define menu select Time History Functions...  to display the Define Time
History Functions dialog box.

62. In this dialog box:

• Click the Add Function From File button to display the Time History Function
Definition dialog box.

• In this dialog box:

À Type ELCEN  in the Function Name edit box.

À Click the Open File button to display the Pick Function Data File dialog box.

À In this dialog box:

ä Locate and highlight the file named Elcentro

ä Click the Open button to return to the Time History Function Definition dialog
box.

ä Type 3 in the Number Of Points Per Line edit box.

ä Select the Time and Function Values option.

ä Click the OK  button twice to exit all dialog boxes.

63. From the Analyze menu select Set Options... to display the Analysis Options dialog box.
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• In this dialog box click the Plane Frame XZ Plane button                    to set the
available degrees of freedom.

• Check the Dynamic Analysis check box, if it is not already checked.

• Click the Set Dynamic Parameters button to display the Dynamic Analysis
Parameters dialog box.

• In this dialog box:

À Type 30 in the Number of Modes edit box.

À In the Type Of Analysis area select the Ritz Vectors option.

À Verify that ACCEL X and ACCEL Z are in the Ritz Load Vectors box in the
Starting Ritz Vectors area.  Move any other vectors out of the Ritz Load Vectors
box

À Confirm that the Include NLLink Vectors box is checked.

À Click the OK button twice to exit all dialog boxes.

64. From the Define menu select Time History Cases...  to display the Define Time History
Cases dialog box.

65. In this dialog box:

• Click the Add New History button to display the Time History Case Data dialog box.

• In this dialog box:

À Type GRAV in the History Case Name edit box.

À Select Nonlinear from the Analysis Type drop-down box.

À Click the Modify/Show button for modal damping to display the Modal Damping
dialog box.

À In this dialog box:

ä Type .02 in the Damping For All Modes edit box.

ä Click the OK button.

À Type 100 in the Number of Output Time Steps edit box.

À Type .1 in the Output Time Step Size edit box.

À Check the Envelopes check box.
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À In the Load drop-down box select GRAV.

À In the Function drop-down box, select RAMP.

À Type 1 in the Scale Factor edit box.

À Click the Add button.

À Click the OK button to return to the Define Time History Cases dialog box.

• Click the Add New History button to display the Time History Case Data dialog box.

• In this dialog box:

À Type ELCN in the History Case Name edit box.

À Select Nonlinear from the Analysis Type drop-down box.

À Click the Modify/Show button for modal damping to display the Modal Damping
dialog box.

À In this dialog box:

ä Type .02 in the Damping For All Modes edit box.

ä Click the OK button.

À Type 1210 in the Number of Output Time Steps edit box.

À Type .01 in the Output Time Step Size edit box.

À Check the Envelopes check box.

À In the Load drop-down box select acc dir 1.

À In the Function drop-down box, select ELCEN.

À Type 32.2 in the Scale Factor edit box.

À Click the Add button.

À Click the OK button twice to exit all dialog boxes.

66. Click the Run Analysis button       to run the analysis.

67. When the analysis is complete check the messages in the Analysis window (there should be
no warnings or errors).  Click the OK button to close the Analysis window.
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68. Click the Start Animation button                         located on the status bar at the bottom of
the screen to animate the first mode shape.

69. Click the Right Arrow button        located on the status bar at the bottom of the screen to
view the next mode shape.

70. Continuing clicking the Right Arrow button        to step through all of the mode shapes.

71. Click the Show Undeformed Shape button        to remove the displayed mode shape.

72. From the File menu select Create Video… and then select Create Time History
Animation Video… to display the Video File dialog box.

73. In this dialog box select the name and location for the video file (*.avi) and click the Save
button.  The Time History Video File Creation dialog box is displayed.

74. In this dialog box:

• Type 50 in the Magnification Factor edit box.

• In the Frame Size (Pixels) edit boxes type 640 by 480.

• Click the OK  button.  The *.avi file is created.

Note:  Once the *.avi file has been created it can be played on any multimedia player that
supports *.avi files.  A program called Media Player is supplied with Windows 95 that
will play *.avi files.  This program can often be found by clicking the Start button,
selecting Programs, then selecting Accessories and finally selecting Multimedia.  No
multimedia player is provided with SAP2000.

Note:  The purpose of this example is to display the capabilities of SAP2000.  The
structural properties of each frame have not been optimized in this example.  Therefore,
great care should be taken in drawing any conclusions about the relative performance
of different structural systems based on this example.


